Cloudn't launch JMXTerm . Is Java in your PATH ?

cloudinsight

#1

安装 Tomcat Slor ActiveMQ Cassandra Kafka 等监控时,都需要采用 JMX 远程监控,修改还配置文件后,执行 info 报错如下:

 /etc/init.d/oneapm-ci-agent info

报错找不到 JAVA 路径,所以自己添加,修改配置文件,添加 JAVA 的路径:

instances:
  - host: localhost
    port: 11099
    user: admin
    password: admin
  #   process_name_regex: .*process_name.* # Instead of specifying a host, and port. The agent can connect using the attach api.
  #                                        # This requires the JDK to be installed and the path to tools.jar to be set below.
  #   tools_jar_path: /usrb/jvm/java-7-openjdk-amd64b/tools.jar # To be set when process_name_regex is set
  #   name: activemq_instance
    java_bin_path: /usr/jvmk1.7.0_79/bin/java # Optional, should be set if the agent cannot find your java executable
  #   # java_options: "-Xmx200m -Xms50m" # Optional, Java JVM options
  #   # trust_store_path: /path/to/trustStore.jks # Optional, should be set if ssl is enabled
  #   # trust_store_password: password
  #   tags:
  #     env: stage
  #     newTag: test

修改完之后重启探针 :

/etc/init.d/oneapm-ci-agent  restart

查看探针状态,是否还有报错

/etc/init.d/oneapm-ci-agent   info

输出如下图就没问题啦!